Issue with Electronic Prescriptions
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jul 21, 2021 - 17:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 10:20 EDT
Investigating
Carestream Dental is investigating reports of an issue with Electronic Presciptions service. Users may be unable to issue prescriptions or be experiencing degraded performance.
Posted Jul 21, 2021 - 10:11 EDT
This incident affected: eServices (Electronic Prescriptions).