Imaging Delays in Image Uploads - Partial - MO
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 13:41 EDT
Identified
We’re aware that some users are experiencing a delay in image uploads and are working to identify the cause of this issue. This status page will be updated upon conclusion of our investigation.
Posted Mar 17, 2021 - 13:18 EDT
This incident affected: Hosted Practice Management and Imaging (OMS Imaging Hosted).