Issue with Multiple Carestream Dental Services
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 14:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2021 - 12:30 EDT
Investigating
We are investigating reports of an issue affecting multiple Carestream Dental services. Users of the following indicated services in this notification may be experiencing a service outage or degraded performance.
Posted Oct 08, 2021 - 07:52 EDT
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted, SoftDent Hosted, PracticeWorks Hosted, OMS Imaging Hosted, Dental Imaging Hosted, Orthodontic Imaging Hosted).