CS Connect Outage
Incident Report for Carestream Dental Status Page
Resolved
A fix has been implemented and the CS Connect service should be fully restored at this time.
Posted Feb 17, 2021 - 12:28 EST
Identified
We have identified a partial outage of our CS Connect service and are working to implement a fix. Some customer scans submitted during the ongoing incident may be inaccessible. These scans may have to be resubmitted once the incident is resolved. We apologize for the impact.
Posted Feb 17, 2021 - 09:53 EST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2021 - 09:14 EST
Investigating
We are currently investigating an outage of our CS Connect service. At this time, all scans submitted during the incident may be inaccessible. These scans may have to be resubmitted once the incident is resolved. We apologize for the impact.
Posted Feb 17, 2021 - 08:58 EST
This incident affected: Imaging Applications (CS Connect and Quick Connect).