Issue with Multiple Carestream Dental Services
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted May 13, 2022 - 10:04 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 17:09 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 17:08 EDT
Investigating
Carestream Dental is investigating reports of an issue with our WinOMS and OrthoTrac Hosted service. Users of this service may be experiencing an outage or degraded performance.
Posted May 12, 2022 - 10:50 EDT
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted).