Issue with Payments Processing - Surcharge Only

Incident Report for Carestream Dental Status Page

Investigating

Carestream Dental is investigating an issue affecting Payments Processing for users with the Surcharging feature enabled. When Surcharging is enabled, applied surcharges may not be reflected automatically on patient ledgers.
Posted Aug 13, 2026 - 16:44 EDT
This incident affects: eServices (Payments Processing).