Issue with CS Connect and Quick Connect

Incident Report for Carestream Dental Status Page

Investigating

Carestream Dental is investigating reports of an issue with our CS Connect and Quick Connect service. Users of these services may experience slowness when uploading scans at this time.
Posted Aug 04, 2026 - 10:11 EDT
This incident affects: Imaging Applications (CS Connect and Quick Connect).