We believe the issue has now been resolved, and service performance has returned to expected levels. Following a period of monitoring, no further slowness has been observed, and the environment remains stable.
As a result, we are closing this case and marking it as Resolved.
We sincerely apologize for the disruption caused and thank you for your patience and understanding while we worked to restore service. Should you experience any further issues, please do not hesitate to contact us and we will be happy to assist.
Posted Jul 28, 2026 - 07:59 EDT
Monitoring
We believe the issue has now been resolved, and service performance has returned to expected levels. Our teams will continue to closely monitor the environment to ensure ongoing stability.
If you continue to experience any issues, please refresh your browser or application and try again.
We sincerely apologize for the disruption caused and thank you for your patience and understanding while we worked to restore service.
Posted Jul 28, 2026 - 06:17 EDT
Investigating
We are aware that the issue has reoccurred, and some users may again experience slowness and intermittent login difficulties.
Our technical teams are actively investigating the cause and working to restore full service stability as quickly as possible. We understand the impact this may have and are treating this with high priority.
We apologize for the continued disruption and appreciate your patience while we work to resolve the issue. Further updates will be provided as soon as more information becomes available.
Posted Jul 28, 2026 - 05:57 EDT
Update
We now believe the issue has been resolved, and services are operating normally. If you continue to experience any issues, please refresh your browser or application and try again.
Our teams will continue to closely monitor the environment to ensure stability and performance remain at expected levels.
We apologize for any inconvenience caused and thank you for your patience and understanding while we worked to resolve the issue.
Posted Jul 28, 2026 - 05:51 EDT
Monitoring
The service remains stable following corrective actions. Users are advised to refresh their browser or application and attempt to log in again if they continue to experience issues.
We are actively monitoring the environment to ensure performance remains normal and will provide further updates if required.
Posted Jul 28, 2026 - 05:35 EDT
Investigating
We are currently investigating reports of users experiencing application slowness and intermittent login issues. Affected users may encounter delays when accessing services, increased page load times, or difficulties signing in.
Our technical teams are actively working to identify the root cause and restore normal service as quickly as possible. We will continue to provide updates as more information becomes available.
We apologize for any inconvenience and appreciate your patience while we work to resolve this issue.
Posted Jul 28, 2026 - 05:22 EDT
This incident affected: Sensei Platform (Sensei Cloud - UK).