Issue with OrthoTrac Hosted
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 19:03 EST
Identified
Our dedicated engineering team has pinpointed the problem and is collaborating closely with Microsoft resolve the issue.
Posted Mar 06, 2024 - 15:06 EST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2024 - 12:09 EST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2024 - 09:10 EST
Update
We are still investigating the partial outage with our Hosted Orthotrac service. Upon further monitoring, we are not seeing any issue with our WinOMS service and that service is fully operational.
Posted Mar 06, 2024 - 07:54 EST
Investigating
Carestream Dental is investigating reports of an issue with our Hosted OrthoTrac and Hosted WinOMS services. Users of this service may be experiencing an outage or degraded performance.
Posted Mar 05, 2024 - 14:37 EST
This incident affected: Hosted Practice Management and Imaging (OrthoTrac Hosted).