Practice Management Outage
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Jul 20, 2024 - 09:11 EDT
Update
Upgrading SoftDent Hosted
Posted Jul 19, 2024 - 19:03 EDT
Identified
The services are resolved, PracticeWorks Hosted, OMS Imaging Hosted, Dental Imaging Hosted and Orthodontic Imaging Hosted.
Posted Jul 19, 2024 - 19:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 12:10 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 11:56 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 11:48 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 11:41 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 08:18 EDT
Update
Sensei DPMS systems are fully operational
Posted Jul 19, 2024 - 06:46 EDT
Investigating
We are currently investigating the impact of the global Crowdstrike outages on the DPMS hosted and Sensei environments.
Posted Jul 19, 2024 - 06:33 EDT
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted, SoftDent Hosted, PracticeWorks Hosted, OMS Imaging Hosted, Dental Imaging Hosted, Orthodontic Imaging Hosted).