Issue with Electronic Prescriptions
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 12:22 EDT
Investigating
Carestream Dental is investigating reports of an issue with our Electronic Prescriptions service. Users of this service may be unable to create certain digital prescriptions.
Posted Jun 14, 2021 - 10:33 EDT
This incident affected: eServices (Electronic Prescriptions).