Issue with Electronic Prescriptions
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Nov 18, 2024 - 15:04 EST
Investigating
Carestream Dental is investigating reports of an issue with Electronic Prescriptions service. Users may be unable to issue prescriptions for controlled substances due to degraded platform of a user verification service named ID me .
Posted Nov 18, 2024 - 11:31 EST
This incident affected: eServices (Electronic Prescriptions).