Issue with Softdent Hosted
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted May 19, 2022 - 13:11 EDT
Investigating
Carestream Dental is investigating reports of an issue with our SoftDent Hosted service. Users of this service may be experiencing an outage or degraded performance.
Posted May 19, 2022 - 12:51 EDT
This incident affected: Hosted Practice Management and Imaging (SoftDent Hosted).