Issue with Insurance Verifications
Incident Report for Carestream Dental Status Page
Update
Dental Insurance Verifications are currently being processed for payers that support eligibility transactions. Medical Insurance Verifications are still offline.
Posted Apr 19, 2024 - 13:07 EDT
Update
Carestream Dental is now using additional trading partners whenever possible to allow the electronic submission of most eligibility requests. Click Learn More for additional information.
Posted Feb 28, 2024 - 16:16 EST
Identified
Carestream Dental is now using additional trading partners whenever possible to allow the electronic submission of most eligibility requests.
Posted Feb 26, 2024 - 14:04 EST
Investigating
Due to our use of our Transaction Management System, we expect to see increased capability to restore insurance verifications (eligibility) over the next 8-12 hours.
Posted Feb 23, 2024 - 17:40 EST
This incident affects: eServices (Insurance Verifications).