Issue with Electronic Prescriptions

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Aug 19, 2021 - 11:00 EDT

Investigating

Carestream Dental is investigating reports of an issue with Electronic Presciptions service. Users may be unable to issue prescriptions or be experiencing degraded performance.
Posted Aug 19, 2021 - 09:37 EDT
This incident affected: eServices (Electronic Prescriptions).