Issue with Electronic Prescriptions
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Sep 01, 2021 - 12:29 EDT
Update
We are continuing to investigate this issue.
Posted Sep 01, 2021 - 11:19 EDT
Investigating
Carestream Dental is investigating reports of an issue with Electronic Presciptions service. Users may be unable to issue prescriptions or be experiencing degraded performance.
Posted Sep 01, 2021 - 10:12 EDT
This incident affected: eServices (Electronic Prescriptions).