Issue with Sensei Cloud - UK

Incident Report for Carestream Dental Status Page

Resolved

We believe this issue has been resolved and services have returned to normal operation.
Posted Apr 14, 2026 - 10:25 EDT

Update

We believe this issue has been resolved and services have returned to normal operation. We will continue to monitor the situation to ensure stability.
Posted Apr 14, 2026 - 08:38 EDT

Monitoring

We believe this issue has been resolved and services have returned to normal operation. We will continue to monitor the situation to ensure stability.
Posted Apr 14, 2026 - 08:37 EDT

Investigating

Carestream Dental is investigating reports of an issue with our Sensei Cloud - UK service. Users may experience degraded performance.
Posted Apr 14, 2026 - 06:23 EDT
This incident affected: Sensei Platform (Sensei Cloud - UK).