Issue with CS Connect and Quick Connect

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jul 31, 2026 - 08:38 EDT

Investigating

Carestream Dental is investigating reports of performance issues with our CS Connect and Quick Connect service. Users of these services may find the application slow to load at this time.
Posted Jul 30, 2026 - 09:12 EDT
This incident affected: Imaging Applications (CS Connect and Quick Connect).