Sensei Cloud - US

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted May 19, 2025 - 08:25 EDT

Identified

Carestream Dental has identified an issue with our Sensei Cloud - US service. At this time, users are unable to print or send a Bulk Statement Worklist.
Posted May 19, 2025 - 08:11 EDT
This incident affected: Sensei Platform (Sensei Cloud - US).