Partial outage on Hosted Practice Management and Imaging
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 09:11 EDT
Investigating
We are currently investigating this issue.
Posted Jun 02, 2021 - 05:57 EDT
This incident affected: Hosted Practice Management and Imaging (Windent Hosted).