Issue with OrthoTrac Hosted
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 09:44 EST
Investigating
Carestream Dental is investigating reports of an issue with our OrthoTrac service. Users of this service may be experiencing an outage or degraded performance.
Posted Feb 08, 2024 - 15:09 EST
This incident affected: Hosted Practice Management and Imaging (OrthoTrac Hosted).