Issue with WinOMS Hosted
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Users may have to log off and back on. Instructions are at this link
Posted Nov 14, 2022 - 12:25 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2022 - 11:07 EST
Investigating
Carestream Dental is investigating reports of an issue with our WinOMS Hosted service. Users of this service may experiencing issues where they are unable to acquire images or unable to use aneshesia monitor integration.
Posted Nov 14, 2022 - 08:40 EST
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted).