Issue with Multiple Carestream Dental services
Incident Report for Carestream Dental Status Page
Resolved
As we bring the impacted services online, updates are now relevant at an individual service level. We are closing this incident so that relevant updates by service can be provided to you as quickly as possible. Therefore; this combined status incident will be closed.
Posted Feb 23, 2024 - 17:36 EST
Update
One of our vendors reported a network outage due to a possible security incident. They disconnected affected services to minimize exposure. The vendor has indicated that they expect services to be offline at least until end-of-day Friday (2/23/24)
Posted Feb 22, 2024 - 19:21 EST
Update
One of our vendors reported a network outage due to a possible security incident. They disconnected affected services to minimize exposure. Expect services to be offline at least until end-of-day Thursday (2/22/24). We're in contact with the vendor for updates on service restoration, which will happen individually. Keep checking for updates.
Posted Feb 22, 2024 - 15:04 EST
Update
One of our vendors reported a network outage due to a possible security incident. They disconnected affected services to minimize exposure. Expect services to be offline at least until end-of-day Thursday (2/22/24). We're in contact with the vendor for updates on service restoration, which will happen individually. Keep checking for updates.
Posted Feb 22, 2024 - 10:37 EST
Update
The service disruption is expected to last at least through the end of today. There is still active work to isolate, troubleshoot and address the cause of this incident. We apologize for the impact of the service disruption.
Posted Feb 21, 2024 - 12:23 EST
Update
We are continuing to investigate this issue.
Posted Feb 21, 2024 - 10:46 EST
Update
We are investigating reports of an issue affecting multiple Carestream Dental services. Users of the following indicated services in this notification may be experiencing a service outage or degraded performance.
Posted Feb 21, 2024 - 10:44 EST
Investigating
Carestream Dental is investigating reports of an issue with Electronic Presciptions service. Users may be unable to issue prescriptions or be experiencing degraded performance.
Posted Feb 21, 2024 - 07:55 EST
This incident affected: eServices (Insurance Claims, Insurance Verifications, Electronic Remittance Advice, Automated Statements, Electronic Prescriptions).