Issue with OrthoTrac Hosted
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jul 29, 2021 - 16:30 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 29, 2021 - 15:41 EDT
Investigating
Carestream Dental is investigating reports of an issue with our OrthoTrac service. Users of this service may be experiencing an outage or degraded performance.
Posted Jul 29, 2021 - 10:35 EDT
This incident affected: Hosted Practice Management and Imaging (OrthoTrac Hosted).