Issue with Payments Processing
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Apr 24, 2024 - 11:24 EDT
Update
Carestream Dental is still investigating issues with our Payments Processing service affecting some of our WinOMS and SoftDent customers using older Payment Processing services. Users of this service may be unable to process new payments. Users of our Payment Manager service are unaffected.
Posted Apr 19, 2024 - 14:11 EDT
Investigating
Carestream Dental is investigating reports of an issue with our Payments Processing service affecting some of our WinOMS and SoftDent customers using older Payment Processing services. Users of this service may be unable to process new payments or be experiencing degraded performance. Users of our latest Payment Manager are unaffected.
Posted Apr 15, 2024 - 14:19 EDT
This incident affected: eServices (Payments Processing).