OrthoTrac and WinOMS Cloud Performance Issues

Incident Report for Carestream Dental Status Page

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 15:42 EDT

Monitoring

Users may have experienced a brief disconnect from the Cloud within the last hour and then slowness upon reconnecting. A fix has been implemented, and we are monitoring the results. If you are experiencing slowness currently, please close the application and then relaunch to resolve. We apologize for any inconvenience. -Cloud Admin
Posted Jul 07, 2025 - 11:02 EDT
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted).