Sensei Cloud - US
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Nov 19, 2024 - 08:16 EST
Identified
Carestream Dental has identified an issue affecting Electronic Prescriptions integration with Sensei Cloud. Sensei Cloud users can still prescribe directly through Clinician as a workaround until the integration is restored. Carestream Dental is actively working to resolve the issue.
Posted Nov 18, 2024 - 10:26 EST
This incident affected: Sensei Platform (Sensei Cloud - US).