Issue with Insurance Claims
Incident Report for Carestream Dental Status Page
Resolved
Dental claims are being processed through our CSD Transaction Management System. 85% of medical claims are now being processed through our Transaction Management System. This service is now considered fully operational. For dental claim processing, some customers may require enrollment with our trading partner. Please contact us if you continue to experience any issues.
Posted Apr 19, 2024 - 13:02 EDT
Update
97% of all dental claims are now being processed through our CSD Transaction Management System. We expect to have a solution for electronic submission of medical claims soon. Click Learn More for additional information.
Posted Mar 05, 2024 - 11:43 EST
Update
Carestream Dental is now using additional trading partners whenever possible to allow the electronic submission of most dental claims. Click Learn More for additional information.
Posted Feb 28, 2024 - 16:17 EST
Identified
Carestream Dental is now using additional trading partners whenever possible to allow the electronic submission of most dental claims.
Posted Feb 25, 2024 - 08:48 EST
Investigating
We have an alternative method to allow many claims to route through other clearinghouses. While this will not work for all payers, we expect that most dental claims should be starting to move through the system for processing over the next 8-12 hours. If you have submitted claims already, there is no need to resubmit.
Posted Feb 23, 2024 - 17:39 EST
This incident affected: eServices (Insurance Claims).