WinOMS - Partial Outage
Incident Report for Carestream Dental Status Page
Resolved
All systems are back online and users are able to access their data. If you have any issues logging back in, you can reach our support staff at Support.US@csdental.com.
Posted Mar 12, 2021 - 08:58 EST
Identified
We’ve identified the cause of the issue in our software and our engineering team is working to get this resolved as soon as possible
Posted Mar 12, 2021 - 08:40 EST
Investigating
We’re aware of an outage affecting some WinOMS customers and are working to identify the cause and appropriate steps to remediate. All data is safe and backed up. This status page will be updated upon conclusion of our investigation.
Posted Mar 12, 2021 - 08:03 EST
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted).