Issue with OMS Imaging Hosted
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jun 20, 2022 - 08:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2022 - 10:53 EDT
Investigating
Carestream Dental is investigating reports of an issue with our OMS Imaging Hosted service. Images taken may not be uploading or users may be experiencing degraded performance.
Posted May 18, 2022 - 07:51 EDT
This incident affected: Hosted Practice Management and Imaging (OMS Imaging Hosted).