Intermittent Issue with WinOMS Hosted and Orthotrac Hosted Applications
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Mar 07, 2024 - 13:53 EST
Investigating
We are investigating reports of intermittent issues with WinOMS Hosted and Orthotrac Hosted services. Some users of these services have reported temporary issues that appear to be resolved after logging off and then relaunching their application after a few minutes.
Posted Mar 07, 2024 - 11:09 EST
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted).