Hosted OrthoTrac partial outage
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Mar 13, 2024 - 11:30 EDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2024 - 10:49 EDT
Investigating
We are currently investigating an outage for some of our OrthoTrac hosted customers.
Posted Mar 13, 2024 - 10:30 EDT
This incident affected: Hosted Practice Management and Imaging (OrthoTrac Hosted).