Issue with PracticeWorks Hosted
Incident Report for Carestream Dental Status Page
Resolved
Working with Citrix and Microsoft Azure, Carestream Dental has applied a fix that is now allowing for customers to access Practiceworks successfully.
Posted Apr 12, 2024 - 13:41 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Friday, April 12th.
Posted Apr 12, 2024 - 08:12 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Thursday, April 11th.
Posted Apr 11, 2024 - 07:02 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Wednesday, April 10th.
Posted Apr 10, 2024 - 09:18 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Tuesday April 9th.
Posted Apr 09, 2024 - 06:59 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident.
Posted Apr 05, 2024 - 08:14 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Thursday April 4th.
Posted Apr 04, 2024 - 07:53 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Wednesday April 3rd.
Posted Apr 03, 2024 - 10:57 EDT
Update
Carestream Dental engineering teams are continuing to work with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Tuesday April 2nd.
Posted Apr 02, 2024 - 10:02 EDT
Update
Carestream Dental engineering teams are working with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Friday March 29th.
Posted Mar 29, 2024 - 08:07 EDT
Update
Carestream Dental engineering teams are working with Citrix to identify and resolve this ongoing incident. We do not expect this incident to be resolved before the end of business today, Wednesday March 27th
Posted Mar 27, 2024 - 11:24 EDT
Investigating
Carestream Dental is investigating reports of an issue with our PracticeWorks Hosted service. Users of this service may be experiencing an outage or degraded performance.
Posted Mar 25, 2024 - 08:44 EDT
This incident affected: Hosted Practice Management and Imaging (PracticeWorks Hosted).