Sensei Cloud - US

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Aug 04, 2026 - 11:02 EDT

Investigating

We are investigating reports that some users are having trouble logging in. This appears to be caused by an internet service problem outside our software, which may affect some users depending on their location or internet provider. Our systems are operational. If you are affected, the issue is likely to clear on its own as the external problem is resolved. We will continue to monitor.
Posted Aug 04, 2026 - 10:33 EDT
This incident affected: Sensei Platform (Sensei Cloud - US).