Electronic Prescription (eRX) Outage
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted May 13, 2021 - 17:47 EDT
Update
This issue with Electronic Prescriptions has been resolved and is now fully functional.
Posted May 13, 2021 - 17:46 EDT
Update
We are continuing to investigate this issue.
Posted May 13, 2021 - 17:45 EDT
Investigating
We are aware that some users are seeing an outage of our ePrescription (eRX) service. We are working to identify the cause and take appropriate steps to remediate. This status page will be updated upon conclusion of our investigation.
Posted May 13, 2021 - 13:17 EDT
This incident affected: eServices (Electronic Prescriptions).