Issue with Softdent Hosted

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Oct 19, 2022 - 12:15 EDT

Investigating

Carestream Dental is investigating reports of an issue with our SoftDent Hosted service. Users of this service may be experiencing an outage or degraded performance.
Posted Oct 19, 2022 - 11:08 EDT
This incident affected: Hosted Practice Management and Imaging (SoftDent Hosted).