Issue with OrthoTrac Hosted

Incident Report for Carestream Dental Status Page

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 18:00 EDT

Investigating

Carestream Dental is investigating reports of an issue with our OrthoTrac service. Users of this service may be experiencing an outage or degraded performance.
Posted Sep 22, 2026 - 12:48 EDT
This incident affected: Hosted Practice Management and Imaging (OrthoTrac Hosted).