After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jul 23, 2026 - 12:46 EDT
Update
Customers are currently unable to log in to our web applications due to an ongoing incident affecting Microsoft Azure authentication services and other Microsoft products globally. Impact may be intermittent, so some users may remain logged in and able to work while others cannot access the applications. More details here. We are monitoring closely and will restore service as soon as the Microsoft incident is resolved.
Posted Jul 23, 2026 - 11:53 EDT
Investigating
Carestream Dental is investigating reports of an issue with our Sensei Cloud - UK service. Users may be unable to login or experiencing degraded performance.
Posted Jul 23, 2026 - 11:16 EDT
This incident affected: Sensei Platform (Sensei Cloud - UK).