Planned Software Updates for Click&Share, AI Insights & Swissmeda Cloud Imaging

Scheduled for Sep 11, 04:00 - 06:00 EDT

Update

We will be undergoing Software updates for Click&Share, AI Insights & Swissmeda Cloud Imaging at Thursday September 11th from 10:00 AM to 12:00 PM Paris time. Services will be unavailable during this maintenance window.
Posted Sep 05, 2025 - 08:34 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 05, 2025 - 08:32 EDT

Scheduled

We will be undergoing Software updates for Click&Share, AI Insights & Swissmeda Cloud Imaging at Thursday September 11th from 10:00 AM to 12:00 PM Paris time. Services will be unavailable during this maintenance window.
Posted Sep 05, 2025 - 04:56 EDT
This scheduled maintenance affects: Imaging Applications (AI Insights, Swissmeda Cloud Imaging, Click & Share).