Issue With Swissmeda Cloud Imaging

Incident Report for Carestream Dental Status Page

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 05:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 05:30 EDT

Investigating

Carestream Dental is investigating reports of an issue with our Swissmeda Cloud Imaging service. Users of these services may be unable to transmit or view images or be experiencing degraded performance.
Posted May 20, 2025 - 04:24 EDT
This incident affects: Imaging Applications (Swissmeda Cloud Imaging).