Issue with Insurance Claims and Statements - WinOMS V10 Hosted

Incident Report for Carestream Dental Status Page

Resolved

After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.

Any claims or statements that did not transmit successfully have now been resubmitted by our engineering team and will appear on your next transmission report.
Posted Aug 13, 2026 - 13:28 EDT

Monitoring

Carestream Dental has identified and resolved the root cause of the outage, and services are now operating normally.

Affected customers may need to reconfigure their eServices account credentials in WinOMS by navigating to Tables > eServices > Configure eClaims.

We are also reviewing claims and statements submitted between August 10 and August 12, as some may not have transmitted correctly. No action is needed on these at this time. We will follow up with next steps in a later update.
Posted Aug 12, 2026 - 14:53 EDT

Investigating

Carestream Dental is investigating reports of an issue affecting electronic Insurance Claims and Automated Statements service only for Hosted WinOMS version 10 users. Users of this service may be unable to transmit new claims or see a delay in processing.
Posted Aug 12, 2026 - 14:25 EDT
This incident affected: eServices (Insurance Claims, Automated Statements).