Issue with CS Connect and Quick Connect
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 10:21 EDT
Update
We are continuing to investigate this issue.
Posted Jul 24, 2024 - 10:21 EDT
Investigating
Carestream Dental is investigating reports of an issue with our CS Connect and Quick Connect service. Users of these services may be unable to transmit or receive new cases or be experiencing degraded performance.
Posted Jul 24, 2024 - 08:24 EDT
This incident affected: Imaging Applications (CS Connect and Quick Connect).