Issue with Multiple Carestream Dental Services
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jan 20, 2022 - 09:14 EST
Investigating
We are investigating reports of an issue affecting multiple Carestream Dental services. Users of the following indicated services in this notification may be experiencing a service outage or degraded performance.
Posted Jan 20, 2022 - 09:09 EST
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, SoftDent Hosted, PracticeWorks Hosted).