CS Connect - Partial Outage
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved. If you are experiencing any issues with this service please email scannersupport@csdental.com.
Posted May 03, 2021 - 13:19 EDT
Monitoring
A fix has been implemented and we are monitoring results. Please click here for additional guidance if you are unable to login. If you have followed that guidance and are still having issues please email scannersupport@csdental.com.
Posted Apr 21, 2021 - 09:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2021 - 17:33 EDT
Investigating
We’re aware that some users are seeing an outage of our CS Connect service. We are working to identify the cause and take appropriate steps to remediate. This status page will be updated upon conclusion of our investigation.
Posted Apr 20, 2021 - 15:12 EDT
This incident affected: Imaging Applications (CS Connect and Quick Connect).