Issue with CS Connect
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Oct 06, 2021 - 14:52 EDT
Investigating
Carestream Dental is investigating reports of an issue with our CS Connect service. Users of this service may be unable to transmit or receive new cases or be experiencing degraded performance.
Posted Oct 06, 2021 - 14:00 EDT
This incident affected: Imaging Applications (CS Connect and Quick Connect).