US Hosted Practice Management Degraded Performance
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 15:26 EST
Monitoring
We have identified that the source of degraded performance for some users is caused by Verizon internet in specific regions. The resolution to this issue will be dependent on action by Verizon for affected customers. Learn more here: downdetector.com/status/verizon/map/
Posted Mar 03, 2021 - 10:14 EST
Investigating
We’re aware that some users are seeing performance degradation in their system and are working to identify the cause and appropriate steps to mediate. This status page will be updated upon conclusion of our investigation.
Posted Mar 03, 2021 - 09:30 EST
This incident affected: Hosted Practice Management and Imaging (WinOMS Hosted, OrthoTrac Hosted, SoftDent Hosted, PracticeWorks Hosted).