Sensei Cloud - US
Incident Report for Carestream Dental Status Page
Resolved
After further monitoring, this incident is considered resolved. Carestream Dental service has been restored to full functionality. Please contact us if you continue to experience any issues.
Posted Jan 10, 2022 - 12:18 EST
Investigating
Carestream Dental is investigating reports of an issue with our Sensei Cloud - US service. Users may be unable to login or experiencing degraded performance.
Posted Jan 10, 2022 - 09:46 EST
This incident affected: Sensei Platform (Sensei Cloud - US).