Issue with Imaging and Case Collaboration (ICC)
Incident Report for Carestream Dental Status Page
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 19:50 EDT
Investigating
Carestream Dental is investigating reports of an issue with our Imaging and Case Collaboration (ICC) service. Users may be unable to connect or experiencing degraded performance.
Posted Jul 13, 2021 - 10:29 EDT
This incident affected: Imaging Applications (Imaging and Case Collaboration (ICC)).